Issue accessing Actito on ENV-1
Incident Report for Actito
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 07:41 CET
Investigating
We are currently investigating this issue.
Posted Nov 21, 2024 - 07:34 CET
This incident affected: ENV-1 : www1.actito.com (North America) (Portal, API, E-mail Campaigns, SMS Campaigns, Scenarios, Reporting, Forms).