A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 11:55 CEST
Investigating
We detected increased latency on our ENV-3 email gateways. This can result in certain images not being displayed in emails or certain links not working or being slow to redirect to the target url. We are currently investigating this issue.
Posted Jul 17, 2025 - 10:44 CEST
This incident affected: ENV-3 : www3.actito.com (Europe) (E-mail Campaigns).