All services are fully operational. Previously impacted campaigns have been resumed and successfully sent.
Posted Mar 20, 2026 - 02:30 CET
Monitoring
The service on ENV-0 has been restored.
Our teams are currently monitoring the platform to ensure stability.
Posted Mar 20, 2026 - 01:20 CET
Update
The incident on ENV-0 is still ongoing.
Our teams are continuing the investigation. There is no significant change since the last update.
We will provide further updates as soon as more information becomes available.
Posted Mar 20, 2026 - 00:27 CET
Update
We are continuing to investigate the incident affecting ENV-0.
Login and campaign execution remain unavailable.
Not all services are impacted. We can confirm that emails sent before the incident are displayed properly, links working. APIs and dataflows are operational.
Our IT team is actively working on a resolution.
Posted Mar 19, 2026 - 23:33 CET
Investigating
We currently have an issue on ENV-0, impacting most of the services on this environment Login in Actito licenses is not possible at the moment
Our IT team is urgently working on fixing this problem.