ACTITO is slow
Incident Report for ACTITO
Resolved
This incident has been resolved.
Posted Oct 04, 2018 - 21:27 CEST
Update
We are continuing to work on a fix for this issue.
Posted Oct 04, 2018 - 20:59 CEST
Identified
ACTITO is currently overloaded. You might experience slowness.

We apologize for any inconvenience that this may cause. We will get things back and running as quickly as possible.
Posted Oct 04, 2018 - 20:30 CEST
This incident affected: Portal.