GDPR Overload
Incident Report for ACTITO
Resolved
MTA is delivering mails at normal speed.

Mail gateway is responding normally to clicks.
Posted May 24, 2018 - 22:58 CEST
Monitoring
We have identified the problems

Message are delivered. Events are resyncronizing
Posted May 24, 2018 - 22:33 CEST
Update
We are continuing to investigate this issue.
Posted May 24, 2018 - 21:46 CEST
Investigating
We are experiencing some issues due to the amount of email sent regarding GDPR.
Posted May 24, 2018 - 21:42 CEST
This incident affected: Portal, Email campaign, and Reporting.