ENV-0
Incident Report for Actito
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 08:52 CEST
Investigating
We are encountering slowness with e-mail sendings on ENV-0. Campaigns are being sent with a reduced speeding rate.
Our IT teams are investigating
Posted Sep 22, 2022 - 16:06 CEST
This incident affected: ENV-0 : www.actito.be (Europe) (E-mail Campaigns).